Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001168Endian FirewallGUIpublic2008-07-28 00:082010-01-21 19:25
Reportermagu 
Assigned Tosimon-endian 
PriorityurgentSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc2 
Target VersionfutureFixed in Version2.2-rc3 
Summary0001168: Pressing enter on initial wizard's change password screen skips the wizard
DescriptionWhen setting up 2.2 RC2, pressing enter on the Change Password form takes you to the main screen, instead of continuing the setup wizard.

/cgi-bin/setup/step1/chdefaultpw.cgi
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001544)
luca-endian (developer)
2008-08-26 14:51

confirmed with firefox and explorer on mini with 2.2
the default button is "cancel" so appear a login prompt that use a standard admin password
(0001550)
simon-endian (developer)
2008-08-27 12:34

pressing enter triggers cancel and now continues the setup wizard by going to the netwizard
(0002114)
luca-endian (developer)
2009-04-08 18:50

The issue is still there, if you press enter you think that the new passwords provided are saved instead the firewall doesn't prompt any error and simply leave the default password.

A normal user will be stuck because the firewall asks for a password that he doesn't know.
(0002965)
luca-endian (developer)
2009-09-17 16:08

Try with firefox or with windows!
The problem is still there..
If you press enter at the end (focus on the last password box) you press cancel instead of apply so the password is not changed.

Tested with 2.3 RC1

- Issue History
Date Modified Username Field Change
2008-07-28 00:08 magu New Issue
2008-07-28 08:15 peter-endian Target Version => 2.2-rc3
2008-07-28 08:15 peter-endian Assigned To => simon-endian
2008-07-28 08:15 peter-endian Status new => assigned
2008-07-28 12:49 peter-endian Priority normal => urgent
2008-08-26 14:51 luca-endian Note Added: 0001544
2008-08-26 16:00 luca-endian Status assigned => confirmed
2008-08-27 12:34 simon-endian Status confirmed => resolved
2008-08-27 12:34 simon-endian Fixed in Version => 2.2-rc3
2008-08-27 12:34 simon-endian Resolution open => fixed
2008-08-27 12:34 simon-endian Note Added: 0001550
2008-10-08 15:30 peter-endian Status resolved => closed
2009-04-08 18:50 luca-endian Note Added: 0002114
2009-04-08 18:50 luca-endian Status closed => feedback
2009-04-08 18:50 luca-endian Resolution fixed => reopened
2009-09-17 16:08 luca-endian Note Added: 0002965
2009-09-17 16:08 luca-endian Status feedback => confirmed
2009-10-21 11:18 christian-endian Target Version 2.2-rc3 => future
2010-01-21 19:25 peter-endian Status confirmed => closed
2010-01-21 19:25 peter-endian Resolution reopened => fixed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker