Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001476Endian FirewallProxy SMTPpublic2008-11-20 19:172012-03-12 17:58
Reporterluca-endian 
Assigned Topeter-endian 
PrioritynormalSeverityfeatureReproducibilityalways
StatusconfirmedResolutionreopened 
PlatformOSOS Version
Product Version2.4.1 
Target VersionfutureFixed in Version2.4.1 
Summary0001476: Automatical adding domain spam.spam and ham.ham
DescriptionTo train spamassassin you can send mail to spam@spam.spam or ham@ham.ham
but it doesn't work if dns record of domain spam it's not the firewall itself.

Currently you have to do it manually.

Could be useful if efw configure this record automatically.
Tagspurple
Attached Files

- Relationships
related to 0001930closedpeter-endian rewrite rebuildhosts integrating it in restartdnsmasq.py 
related to 0000095acknowledged training is not working as described on endian.it 

-  Notes
(0002681)
peter-endian (administrator)
2009-06-25 22:17

-> create a file in /etc/dnsmasq/hosts.d/
(0004027)
baldy (reporter)
2010-03-12 13:10
edited on: 2010-03-12 13:36

Sending mail to spam@spam.spam or ham@ham.ham does not work in 2.3 either.

Regards,

Klaas-Jan

(0004275)
luca-endian (developer)
2010-05-27 17:29

maybe mail routing is also required
(0004276)
luca-endian (developer)
2010-05-27 17:54

on a system with dns an mail routing configured if I send a mail to spam@spam.spam I get this the mail queue:

E4F861CA3D5 637 Thu May 27 11:51:39 luca endian.com
                                             (mail system configuration error)
                                         spam@spam.
(0005260)
Anonymous (viewer)
2010-12-01 15:05
edited on: 2010-12-01 15:17

upgraded from 2.4.0 to 2.4.1 and the issue is always true:

(mail system configuration error)
                                         spam@spam.spam

transport.db have:

spam.spam sa-spam:
ham.ham sa-ham:

more info from logs:
postfix/pipe[9083]: warning: file /etc/postfix/master.cf: service sa-spam: unknown macro name: "SENDER"
and:
postfix/pipe[9086]: D561B21A15: to=<spam@spam.spam>, relay=sa-spam, delay=2441, delays=2441/0.02/0/0, dsn=4.3.5, status=deferred (mail system configuration error)

(0006179)
luca-endian (developer)
2011-05-03 10:21
edited on: 2011-05-03 10:23

On 2.4.1

- aliases is correct
- transport file is correct
- master.cf file is correct

Onlye the sa-wrapper behaves something weird:
root@efw_master:~ # sa-wrapper
Use of uninitialized value in pattern match (m//) at /usr/bin/sa-wrapper line 81.
Use of uninitialized value in string eq at /usr/bin/sa-wrapper line 82.
Use of uninitialized value in string eq at /usr/bin/sa-wrapper line 82.
Use of uninitialized value in string eq at /usr/bin/sa-wrapper line 82.
Use of uninitialized value in string eq at /usr/bin/sa-wrapper line 82.
I don't recognize your domain ! at /usr/bin/sa-wrapper line 83.

(0006413)
ra-endian (administrator)
2011-05-20 15:34

The problem is that the /etc/postfix/master.cf contains
sa-spam unix - n n - - pipe user=amavis:amavis argv=/usr/bin/sa-wrapper spam ${SENDER}
sa-ham unix - n n - - pipe user=amavis:amavis argv=/usr/bin/sa-wrapper ham ${SENDER}

instead of:
sa-spam unix - n n - - pipe user=amavis:amavis argv=/usr/bin/sa-wrapper spam ${sender}
sa-ham unix - n n - - pipe user=amavis:amavis argv=/usr/bin/sa-wrapper ham ${sender}

all the sender domains need also by configured under incoming domains, then only that sender domains are accepted for the spam training.
(0007743)
konus (reporter)
2012-03-06 10:46

Is the problem solved in 2.5?
(0007750)
peter-endian (administrator)
2012-03-12 17:58

$SENDER -> $sender
is fixed in 2.5

should work then. can you confirm?

- Issue History
Date Modified Username Field Change
2008-11-20 19:17 luca-endian New Issue
2008-11-20 19:20 peter-endian Target Version => future
2009-06-09 21:34 peter-endian Relationship added related to 0001930
2009-06-25 22:16 peter-endian Assigned To => peter-endian
2009-06-25 22:17 peter-endian Note Added: 0002681
2010-03-12 13:10 baldy Note Added: 0004027
2010-03-12 13:36 baldy Note Edited: 0004027
2010-05-27 17:29 luca-endian Note Added: 0004275
2010-05-27 17:54 luca-endian Note Added: 0004276
2010-09-14 12:21 luca-endian Relationship added related to 0000095
2010-09-14 12:22 luca-endian Tag Attached: purple
2010-09-23 12:56 peter-endian Status new => resolved
2010-09-23 12:56 peter-endian Resolution open => fixed
2010-09-23 12:56 peter-endian Fixed in Version => 2.4.1
2010-11-22 12:51 peter-endian Status resolved => closed
2010-12-01 15:05 Anonymous Note Added: 0005260
2010-12-01 15:05 Anonymous Status closed => feedback
2010-12-01 15:05 Anonymous Resolution fixed => reopened
2010-12-01 15:17 Anonymous Note Edited: 0005260
2011-05-03 10:21 luca-endian Note Added: 0006179
2011-05-03 10:22 luca-endian Status feedback => confirmed
2011-05-03 10:23 luca-endian Note Edited: 0006179
2011-05-03 10:23 luca-endian Product Version 2.2-rc3 => 2.4.1
2011-05-20 15:34 ra-endian Note Added: 0006413
2012-03-06 10:46 konus Note Added: 0007743
2012-03-12 17:58 peter-endian Note Added: 0007750

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker