SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0001510: www.msnbc.msn.com is being block - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001510Endian FirewallProxy HTTPpublic2008-12-14 01:102009-10-27 12:01
Reporterwharfratjoe 
Assigned Tosimon-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionFixed in Version2.2 
Summary0001510: www.msnbc.msn.com is being block
DescriptionIssue:
I receive a blank white page when browsing to www.msnbc.msn.com using IE or Firefox.

Details:
( http://www.nabble.com/Endian-2.2RC3-is-blocking-msnbc.msn.com-to20984562.html [^] )

Per the KB article found here: http://kb.endian.com/entry/59/ [^]
I have this whitelisted as follows:
www.msnbc.msn.com

I also tried the following:
*msnbc.msn.com/*
The issue seems to be how msnbc.msn.com is see accepting the connections from endian. Again this is the exact same symptoms IPCOP had until I used the work around I found (see my first post here for details).

IPOCP has same issue and their fix and more info on this can be found here:
http://www.ipcops.com/phpbb3/viewtopic.php?f=3&t=11619 [^]


Recent Endian 2.2 RC3 Squid Logs:

root@storbaelt:/var/log # tail -f /var/log/squid/access.log | grep 'msnbc'
Dec 13 17:01:19 storbaelt squid[5811]: 1229216479.539 97 127.0.0.1 TCP_MISS/200 430 GET http://www.msnbc.msn.com/id/28212191 [^] - DIRECT/207.46.150.50 text/html
Dec 13 17:01:19 storbaelt squid[5811]: 1229216479.544 107 172.16.0.50 TCP_MISS/200 496 GET http://www.msnbc.msn.com/id/28212191 [^] - FIRST_UP_PARENT/content1 text/html
Dec 13 17:02:49 storbaelt squid[5811]: 1229216569.889 93 127.0.0.1 TCP_MISS/200 430 GET http://www.msnbc.msn.com/ [^] - DIRECT/207.46.245.33 text/html
Dec 13 17:02:49 storbaelt squid[5811]: 1229216569.899 118 172.16.0.50 TCP_MISS/200 496 GET http://www.msnbc.msn.com/ [^] - FIRST_UP_PARENT/content1 text/html
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0001083closedsimon-endian http://msnbc.msn.com [^] does not work with squid (chunked header) 

-  Notes
(0001871)
simon-endian (developer)
2008-12-15 08:58

can you try with the fix descriped in 0001083

> the problem is related to exactly this directive in squid.conf: header_access Via deny all

comment this line out in /etc/squid/squid.conf.tmpl

Regards Simon
(0001877)
wharfratjoe (reporter)
2008-12-15 16:50

Thank you Simon. The fix in ticket 0001083 worked.

- Issue History
Date Modified Username Field Change
2008-12-14 01:10 wharfratjoe New Issue
2008-12-14 01:10 wharfratjoe Assigned To => simon-endian
2008-12-15 08:55 simon-endian Relationship added duplicate of 0001083
2008-12-15 08:58 simon-endian Note Added: 0001871
2008-12-15 08:58 simon-endian Status new => feedback
2008-12-15 16:50 wharfratjoe Note Added: 0001877
2008-12-18 09:14 simon-endian Status feedback => resolved
2008-12-18 09:14 simon-endian Fixed in Version => 2.2
2008-12-18 09:14 simon-endian Resolution open => fixed
2009-10-27 12:01 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker