Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001953Endian FirewallNetwork related (VPN, uplinks)public2009-06-18 14:472011-02-01 16:10
Reporterluca-endian 
Assigned Topeter-endian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusconfirmedResolutionreopened 
PlatformOSOS Version
Product Version2.2-rc3 
Target VersionfutureFixed in Version 
Summary0001953: dashboard should display which uplink currently has the default route
DescriptionIt seems that if you disable and re-enable a secondary uplink, it will become the default uplink. The default route will be through that uplink, and this doesn't make any sense..

Tried with main eth static and secondary pppoe.
Steps to reproduce:
- both uplinks are managed without ping hosts option
- disable managed on secondary (pppoe) uplink
- deactivate uplink
- re-activate uplink (don't set managed)

Check via console with route command you will find out that the default route is the secondary uplink.

Even if you wait things don't change. (after 1 hour it was still the same)

It doesn't happen, fortunately, if the pppoe connection goes down.
Tagspurple
Attached Files

- Relationships
related to 0001955closedpeter-endian main.cgi: display which uplink actually is the default gateway 
related to 0001956new main.cgi, interfaceeditor: restart button 

-  Notes
(0002636)
luca-endian (developer)
2009-06-18 14:56

Maybe related with http://bugs.endian.it/view.php?id=1467 [^]
(0002638)
peter-endian (administrator)
2009-06-18 15:02

that's correct and it is what you want.

if you remove the managed flag it means the uplink is managed by you manually.
if you bring the uplink up, it means you want to use *that* uplink now. therefore it has also the default gateway.
as long as you don't tick on the managed flag this remains so.
if you have more than one unmanaged uplinks, the last dialed in uplink will have the default gateway.
(0002640)
luca-endian (developer)
2009-06-18 15:28

It is not really an expected behavior in my opinion.
It should be noticed somewhere, because someone maybe just want to restart a secondary uplink and doesn't imagine that this can cause a downtime on the main as well.

Actually it can be useful a graphical way to change the default route in some circumstances but in this way it's is just unexpected.
Probably an additional control to select the default gateway would be useful.
(0002644)
peter-endian (administrator)
2009-06-19 13:13

If you disable the logic of the uplinksdaemon (set unmanaged) i think it should be clear that you want the uplinks doing what *you* want and not what the uplinksdaemon wants.
If you then bring an uplink up manually, normally you want that that uplink will also be used.
So i think the behaviour is not so bad.

You can restart an uplink by stopping it and putting it back managed, then it will be started automatically. Ok, a restart button maybe would not be that bad.

But you are right with visualization. You will not see which is the actual default gateway. We should change that.

And probably it is also missing in documentation, that can be. Should add it as well.

- Issue History
Date Modified Username Field Change
2009-06-18 14:47 luca-endian New Issue
2009-06-18 14:47 luca-endian Assigned To => peter-endian
2009-06-18 14:47 luca-endian Tag Attached: purple
2009-06-18 14:54 luca-endian Relationship added related to 0001856
2009-06-18 14:56 luca-endian Note Added: 0002636
2009-06-18 15:02 peter-endian Note Added: 0002638
2009-06-18 15:03 peter-endian Status new => closed
2009-06-18 15:03 peter-endian Resolution open => no change required
2009-06-18 15:28 luca-endian Note Added: 0002640
2009-06-18 15:28 luca-endian Status closed => feedback
2009-06-18 15:28 luca-endian Resolution no change required => reopened
2009-06-19 13:13 peter-endian Note Added: 0002644
2009-06-19 13:16 peter-endian Issue cloned: 0001955
2009-06-19 13:16 peter-endian Relationship added related to 0001955
2009-06-19 13:25 peter-endian Issue cloned: 0001956
2009-06-19 13:25 peter-endian Relationship added related to 0001956
2009-07-24 11:15 luca-endian Status feedback => confirmed
2009-11-25 18:53 peter-endian Assigned To peter-endian =>
2010-09-21 21:34 peter-endian Summary default route is switched to other uplinks => dashboard should display which uplink currently has the default route
2010-09-21 21:37 peter-endian Target Version => future
2011-01-20 15:06 ra-endian Customer Occurencies => 0
2011-02-01 09:34 ra-endian Severity major => minor
2011-02-01 16:10 lorenzo-endian Assigned To => peter-endian

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker