Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002312Endian FirewallHardware related (kernel, drivers, hardware)public2009-10-28 22:202011-11-17 12:06
ReporterRalf 
Assigned Topeter-endian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.3 
Target VersionfutureFixed in Version2.4 
Summary0002312: error message "unable to make root filesystem"
DescriptionWhile installing Endian 2.3 error message "unable to make root filesystem" shows up.
- Language selection -> English
- Welcome page
- install -> yes
- no console
- "Partitioning disk ..."
- "Make root filesystem ..."
- error message "unable to make root filesystem"
Additional InformationHardware:
Compaq ProLiant DL360
Integrated Smart Array Controller ver 1.50
2 x 18 GB SCSI in RAID 1 configuration
Tagspurple
Attached Files

- Relationships
has duplicate 0002261closed Installation Fails at creating Root partition 
has duplicate 0002666closed Can't install on HP DL385 unless I create device files manually 
has duplicate 0003075closedpeter-endian Could not install endian 2.4 on HP DL360 G5 
related to 0002961closedpeter-endian lvcreate failes on Smart Array Controller 
related to 0002945closedpeter-endian error message "unable to make root filesystem" 

-  Notes
(0003163)
peter-endian (administrator)
2009-10-29 13:11

do you use the hardware raid? may be that that controller is not supported

can you check on console 2 (alt-f2) which error will be printed out there?
(0003187)
Ralf (reporter)
2009-10-29 21:57

I just changed back to Endian 2.2 ... will try the next few days again ...

I use hardware raid. My hardware runs with Endian 2.2 without problem. The only issue was/is 0000675. This seems to be solved with Endian 2.3 (or maybe not completly).
(0003189)
bodie (reporter)
2009-10-30 09:20
edited on: 2009-10-30 09:24

Have been running Endian Community on a HP DL380 g3 - same as a DL360 for a while now .. and decided to reinstall to the new version 2.3
however the install just gets past the partitioning stage then errors

Unable to make root file system

hitting F2 and looking at the logs states

Running Command: /bin/mkfs.ext3 -b 4096 /dev/cciss/c0d0p5
mke2fs 1.39 (29-may-2006)
Could not stat /dev/cciss/c0d0p5 --- no such file or directory

the device apparently does not exist; did you specify it correctly.

only option is to reboot.

Checking /dev/c0d0p5 - and correct it doesn't exist - checked install on a standard HP (HP d51, IDE/PATA drives) and install works.

system did work with 2.2 but 2.3 rc and 2.3 both have the same error

bodie
Compaq ProLiant DL380
Integrated Smart Array Controller ver 1.50
2 x 18 GB SCSI in RAID 1 configuration

(0003240)
bodie (reporter)
2009-11-05 10:55

ok work around ...

once booted up to blue screen on Endian 2.3 press alt f3 - to get to the shell
type the following

mknod -m660 /dev/cciss/c0d0p5 b 104 5
mknod -m660 /dev/cciss/c0d0p6 b 104 6
mknod -m660 /dev/cciss/c0d0p7 b 104 7

then press alt F1 and continue

looks like a small bug but hope this helps

bodie
Compaq ProLiant DL380
Integrated Smart Array Controller ver 1.50
2 x 18 GB SCSI in RAID 1 configuration
(0004098)
Dataforce (reporter)
2010-03-24 21:09

The same work around is required for a DL360 G1 which uses the cpqarray driver and creates devices as /dev/ida/c0d0pX however instead of using 104 above, you need to use 72.

Eg:

mknod -m660 /dev/ida/c0d0p5 b 72 5
mknod -m660 /dev/ida/c0d0p6 b 72 6
mknod -m660 /dev/ida/c0d0p7 b 72 7

Once booted properly (ie not the installer) this is not needed and works just fine
(0004479)
peter-endian (administrator)
2010-06-10 18:22

i'm trying to fix this, but have no hardware at hand.

can someone tell me please if there have been /dev/cciss!c0d0pX nodes created instead of /dev/cciss/c0d0pX? note the ! instead of /

i think this could be the following nash bug:
https://bugzilla.redhat.com/show_bug.cgi?id=196360 [^]


if it would be that bug we can fix it for all controllers
in the meantime we will workaround this by creating the nodes
(0004480)
peter-endian (administrator)
2010-06-10 20:01

ok, that was bullshit

our nash has this bug already fixed and the read problem is not that the nodes are not created at all, but that only the first 5 nodes are created but 2.3 needed 7 partitions.

this is fixed in 2.4 since we moved to lvm and now need only 3 device files
(0005329)
Anonymous (viewer)
2010-12-09 04:51

Hi bodie

My system HP Proliant DL380 G3 (72 GB x 2 Raid 0)
Your solution working for me, Thanks many time :D

- Issue History
Date Modified Username Field Change
2009-10-28 22:20 Ralf New Issue
2009-10-29 13:11 peter-endian Note Added: 0003163
2009-10-29 13:11 peter-endian Status new => feedback
2009-10-29 21:57 Ralf Note Added: 0003187
2009-10-30 09:20 bodie Note Added: 0003189
2009-10-30 09:24 bodie Note Edited: 0003189
2009-10-31 00:58 bodie Note Added: 0003201
2009-10-31 01:00 bodie Note Edited: 0003201
2009-11-05 10:23 bodie Note Deleted: 0003201
2009-11-05 10:55 bodie Note Added: 0003240
2009-11-25 16:15 peter-endian Target Version => future
2009-11-25 16:15 peter-endian Status feedback => acknowledged
2009-11-25 18:04 peter-endian Relationship added has duplicate 0002261
2010-02-11 11:26 peter-endian Relationship added has duplicate 0002666
2010-03-24 11:54 ra-endian Severity block => major
2010-03-24 11:54 ra-endian Category Installation => Hardware related (kernel, drivers, hardware)
2010-03-24 21:09 Dataforce Note Added: 0004098
2010-05-12 09:48 luca-endian Tag Attached: purple
2010-06-07 10:53 peter-endian Relationship added related to 0002961
2010-06-07 10:55 peter-endian Relationship added related to 0002945
2010-06-10 18:22 peter-endian Note Added: 0004479
2010-06-10 20:01 peter-endian Note Added: 0004480
2010-06-10 20:01 peter-endian Status acknowledged => resolved
2010-06-10 20:01 peter-endian Fixed in Version => 2.4
2010-06-10 20:01 peter-endian Resolution open => fixed
2010-06-10 20:01 peter-endian Assigned To => peter-endian
2010-09-20 17:29 peter-endian Relationship added has duplicate 0003075
2010-11-22 12:51 peter-endian Status resolved => closed
2010-12-09 04:51 Anonymous Note Added: 0005329
2010-12-09 04:51 Anonymous Status closed => feedback
2010-12-09 04:51 Anonymous Resolution fixed => reopened
2011-11-17 12:05 lorenzo-endian Status feedback => closed
2011-11-17 12:06 lorenzo-endian Resolution reopened => fixed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker