Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000264Endian FirewallNetwork related (VPN, uplinks)public2007-09-25 11:532010-11-22 12:51
Reporterclubbing80s 
Assigned Topeter-endian 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionfutureFixed in Version2.4 
Summary0000264: Active directory authentication for openvpn
DescriptionI got this in reply to one of my postings, it wasn't what I wanted but is a great idea ...
It provides autentication for openvpn against and active directory server...
hope it helps ..

#!/usr/bin/perl

use Net::LDAP;

$USER=$ENV{'username'};
$PASS=$ENV{'password'};


$ldap = Net::LDAP->new( 'ldap://172.24.254.1' [^] ) or die "$@";
#$mesg = $ldap->bind ; # an anonymous bind
$mesg = $ldap->bind( "$USER\@domain.com",
 password => "$PASS"
#$mesg = $ldap->bind( "CN=$USER,CN=Users,DC=domain,DC=com",
# password => "$PASS"
);


if ($mesg->code) {
 die $mesg->error;
exit 1;
} else {
# print "Auth OK\n";
 exit 0;
 }

this works for AD. you may have to tweak it for your LDAP.
Tagsknowledgebase
Attached Filespatch file icon openvpn-additional-config-save-persistent.patch [^] (2,523 bytes) 2010-09-06 12:25 [Show Content]

- Relationships

-  Notes
(0000545)
peter-endian (administrator)
2007-10-27 20:32

cool!

we will consider it for future plannings.
thank you
(0000862)
Anonymous (viewer)
2008-01-28 21:25
edited on: 2008-07-11 05:11

Information on how to implement this on OpenVPN would be greatly appreciated.

Or if the kind gurus of Endian could implement the OpenVPN Auth-LDAP plugin out-of-the-box it would make life even easier. Even if you don't include the GUI straigth away.

[[Update]]
Sent an e-mail to support@endian.it with a modified version of the Python script used for authentication by OpenVPN. It is possible to authenticate against LDAP or Active Directory without installing any extensions or libraries.

(0001377)
steven (reporter)
2008-06-26 22:42

would also like to see this feature included in later versions
(0004010)
peter-endian (administrator)
2010-03-10 15:43

functionality is implemented now, but has no GUI implementatiion
here is how to configure it: http://kb.endian.com/entry/64/ [^]
(0004685)
n9yty (reporter)
2010-08-18 06:00

Since anything done in the GUI overwrites the method linked to, it is not very reliable. Is there a way to make this persist?
(0004709)
peter-endian (administrator)
2010-09-06 12:24

GUI does not overwrite it anymore.

I attached a patch in order that you can fix it manually.

- Issue History
Date Modified Username Field Change
2007-09-25 11:53 clubbing80s New Issue
2007-10-27 20:32 peter-endian Status new => closed
2007-10-27 20:32 peter-endian Note Added: 0000545
2007-10-27 20:32 peter-endian Resolution open => no change required
2008-01-28 21:25 Anonymous Status closed => feedback
2008-01-28 21:25 Anonymous Resolution no change required => reopened
2008-01-28 21:25 Anonymous Note Added: 0000862
2008-01-28 22:50 Anonymous Note Edited: 0000862
2008-01-29 13:19 peter-endian Tag Attached: knowledgebase
2008-01-29 13:20 peter-endian Target Version => 2.3
2008-06-26 22:42 steven Note Added: 0001377
2008-07-11 05:11 Anonymous Note Edited: 0000862
2008-09-10 17:58 chris-endian Target Version 2.3 => future
2010-03-10 15:43 peter-endian Note Added: 0004010
2010-03-10 15:43 peter-endian Status feedback => resolved
2010-03-10 15:43 peter-endian Fixed in Version => 2.3
2010-03-10 15:43 peter-endian Resolution reopened => fixed
2010-03-10 15:43 peter-endian Assigned To => peter-endian
2010-08-18 06:00 n9yty Note Added: 0004685
2010-08-18 06:00 n9yty Status resolved => feedback
2010-08-18 06:00 n9yty Resolution fixed => reopened
2010-09-06 12:24 peter-endian Note Added: 0004709
2010-09-06 12:25 peter-endian File Added: openvpn-additional-config-save-persistent.patch
2010-09-06 12:25 peter-endian Status feedback => resolved
2010-09-06 12:25 peter-endian Fixed in Version 2.3 => 2.4
2010-09-06 12:25 peter-endian Resolution reopened => fixed
2010-11-22 12:51 peter-endian Status resolved => closed

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker