SYSTEM WARNING: 'date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in '/usr/share/mantis/www/core.php' line 264

0004554: BCM 5788 - MantisBT Endian Bugtracker
Endian Issue Tracker





Please see now our new Bugtracker system: JIRA








View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004554Endian FirewallHardware related (kernel, drivers, hardware)public2013-07-17 22:222018-01-14 03:31
Reportermarioeirea 
Assigned ToAnonymous 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.5 
Target VersionFixed in Versionfuture 
Summary0004554: BCM 5788
DescriptionError at startup:

tg3: Problem fetching invariants of chip, aborting.

After start up, network adapters are unavailable.
Additional InformationThis seems to fix the problem but only can be done after system has booted:

modprobe -r broadcom
modprobe -r tg3
modprobe broadcom
modprobe tg3
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0000001closedpeter-endian Creating a backup results into a blank "Backup Sets" list 

-  Notes
(0008446)
marioeirea (reporter)
2013-07-17 22:31

I meant BCM57788
(0008538)
kieronrob (reporter)
2013-09-25 14:03

This is how I solved it:

1. Connected an ASIX USB NIC and configured it as GREEN
2. Connected a Conexant USB ADSL Modem
3. Connect to the Endian and enable SSH
4. Connect via WinSCP
5. Edit /etc/modprobe.d/local.conf and add the following line at the end: install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3
6. Save
7. Edit /etc/modprobe.d/dist.conf and add the following lines at the end: install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3;
install skfp /sbin/modprobe marvell; /sbin/modprobe --ignore-install skfp. Note that these are two seperate lines!
8. Save
9. Reboot
10. Go into the "Network Configuration" menu on the dashboard and the NICs will be available to configure as you wish.
11. Remove the USB NIC if you wish.

I have tried this and it works, the cards I have are listed as follows in the lspci output:

01:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57788 Gigabit Ethernet PCIe (rev 01)

lspci -n show it as the following:

01:00.0 0200: 14e4:1691 (rev 01)

If it stops or gives trouble, I will update.
(0009177)
Anonymous (viewer)
2018-01-14 03:31

1"'`--

- Issue History
Date Modified Username Field Change
2013-07-17 22:22 marioeirea New Issue
2013-07-17 22:31 marioeirea Note Added: 0008446
2013-09-25 14:03 kieronrob Note Added: 0008538
2017-05-16 18:43 Anonymous Status new => feedback
2018-01-14 03:31 Anonymous Note Added: 0009177
2018-01-14 03:31 Anonymous Relationship added duplicate of 0000001
2018-01-14 03:31 Anonymous Status feedback => resolved
2018-01-14 03:31 Anonymous Fixed in Version => 1
2018-01-14 03:31 Anonymous Resolution open => fixed
2018-01-14 03:31 Anonymous Assigned To => Anonymous
2018-01-14 03:31 Anonymous Status resolved => closed
2018-01-14 03:31 Anonymous Fixed in Version 1 => future

Copyright © 2005-2008 Endian, SRL. All rights reserved.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker